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Physics 344                                                                    Lab 1 
Getting to Know The Sky and IDL 

 
Due: Thursday, September 13 
Text Reference: Chapters 1, 2 and 3 
 
 
Purpose: Computers are ubiquitous in astronomy today – they control telescopes and instruments and 
are required to display, manipulate, and analyze images from detectors.  We will be using a number of 
programs in this course, including The Sky to control the telescope, CCDSoft to operate the CCD 
cameras, and IDL for imaging processing and analysis.  This lab introduces you to The Sky running on 
windows PCs and IDL running on the Linux computer Astrolab. 
 
Interactive Data Language (IDL) is a commercial program designed for working with images, and is 
widely used in astronomy, especially in space sciences.  It will be our primary tool for both display and 
quantitative analysis of the images that we will obtain in this course.  As its name implies, IDL is 
interactive – you can type commands into it one at a time and see the results.  It is also a programming 
language – you can define new commands by writing programs using the basic commands of the 
language.  Some of the “basic” commands are quite complex and most commands are equally able to 
operate on scalars or one, two, or three-dimensional numeric arrays.  This makes it possible to perform 
complex operations simply.  For example, the command c = a + b adds image a to image b and put the 
result into a new image c by carrying out the operations c(1,1) = a(1,1)+b(1,1), c(1,2)=a(1,2)+b(1,2), …, 
c(n,m)=a(n,m)+b(n,m), where a and b are two dimensional arrays of numbers, each of size n x m.  If a 
and b were simple numbers, or one or three-dimensional arrays, the same command would add them 
appropriately and create an output object c of the correct type and size. 
 
IDL is used by astronomers around the world and a number of freeware program packages are available 
to perform common astronomical tasks.  We have included some of the most popular and useful of these 
packages in our IDL libraries.  These tasks often involve extracting quantitative information from 
images, such as “how big is a feature in an image?” or “how bright is the image of a star?”.  This is 
rather different from the kinds of image manipulation performed by packages such as Photoshop, which 
are primarily concerned with manipulating the visual appearance of an image (contrast, color balance, 
etc.). 
 
Procedure:  Each student should work independently on this assignment. 
 
The first part of the lab uses the computers in the classroom or the dome.  I have requested that you get 
key-card access to these locations (and the building) for the rest of the course.  I will keep you posted on 
progress.  If you have problems during the semester, see Ms. Cascio in Physics & Astronomy room 326 
during normal working hours (8:30 AM – noon, 1:00 – 4:30 PM). 
 
The second part of the lab uses the computer Astrolab, which lives in the machine room of the Serin 
Physics Lab.  You will connect to this computer using the VNC program, which gives you remote 
access to a desktop on Astrolab.  You can use VNC on the computer in the classroom, but you will 
probably find it more convenient to set up VNC on other computers (there is also a web-browser 
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option).  So, the first step for this part is to follow the instructions on the VNC write-up handed out in 
class and available on the class websites. 
 
Part I: 
Carry out the following steps on either the computer in dome or the computer in room 401 below.  Your 
report should answer all of the questions below and also state the date and time that you carried out 
these exercises.   
 
1) Log into one of the computers with username “ph344” and password “orion”.   
2) Start The Sky by clicking on the icon on the desktop.  Note that a large number of options can be set 

using the menus, with some of the more common ones also available using the buttons on the 
toolbars at the top of the window (note that if you leave the mouse stationary over a button for a 
short time, a tooltip describing the button will pop up).  Start by checking that The Sky is reasonably 
set up for the class.  It should be OK, but you never know if someone has left it in an odd state….  
When exiting The Sky, you should always answer NO to the question about saving changes that have 
been made in order to preserve the reasonable default state. 

a. Pull down the View menu, and click on Status Bar; make sure that the Visible box is checked.  
If they are not already set, check the Equatorial box in Cursor Position, and the Field width, 
Date, and Time boxes in Other Options.  Then click on OK – this will display the date and 
time on the status bar at the bottom of The Sky’s window. 

b. Pull down the Data menu, and click on Location.  On the Predefined List tab, select the 
Schommer Observatory under the User-Defined Locations item and then click on Set 
Location.  Under the Data menu, click on Time and set the date to September 13, 2018, and 
the time to 8:00 pm.  Note that the sky display will adjust to the selected location and time.  
(After you have completed this assignment, you may want to experiment with different sites 
and/or dates and times – for example, to see what is happening at the Southern African Large 
Telescope (SALT) observatory, use the South African Astronomy Observatory location from 
the Observatories database.) 

c. Q1)  What is the latitude, longitude, and altitude adopted for the Schommer Observatory in 
The Sky? 

d. Open the Display Explorer item on the View menu.  Under Solar system, make sure that 
Planets, Sun, and Moon are checked to display these objects.  You can look at what kinds of 
Stellar and Non-stellar objects can be displayed, though most of these are more conveniently 
turned on or off with buttons on the toolbar.  When you are done, dismiss the Display 
Explorer to get it out of the way. 

e. Open the Reference lines item on the View menu.  Make sure that Constellation Lines, 
Ecliptic, Local Horizon, and Meridian are checked.  You can turn these on and off to see 
what lines these are (you have to click OK for the change to take effect).  Also be sure that 
the North/East indicator is turned on (it is useful for indicating the orientation of the display 
when very zoomed in).  Most of the reference lines can also be turned on and off with the 
Reference objects → Reference lines item in the Display Explorer – this is less convenient, 
but there the properties of the lines are also alterable.  Dismiss the panel when done. 

3) Use the toolbar buttons to experiment with displaying different classes of objects, selecting the 
various display viewpoints (N, E, S, W, and Z – this last for zenith-centered, the default at startup), 
zooming and panning, and displaying various grids.  Note that as you zoom in to greater levels of 
detail (in smaller fields of view), more objects are displayed.  The default stellar display for the 
whole sky (Z viewpoint) shows more stars than are visible in our light-polluted skies.  The faint 
magnitude limit of the stars displayed is adjustable in the Display Explorer (expand Stellar and use 
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Display Properties under the Star item to vary the faint magnitude limit), however I have found that 
it is generally best to just use the defaults. 

4) Note how clicking on an object in the display brings up a panel of information on it.  Return to the 
zenith-centered display (Z button), if necessary.  If the date and time are set to the 8:00 PM on 
September 13, 2018, then there will be a bright star (bigger dot), Vega, near the zenith (the center of 
the circular display).  Click on it and make sure that the “More Information” mode of the Object 
Information box is selected. 

a. Q2)  List all of the names of Vega (Flamsteed-Bayer is a name).  List the equatorial and 
horizon coordinates.  Finally, list the magnitude, spectral type, and distance (in parsecs) of 
the star. 

b. Q3)  Locate the other two bright stars that, along with Vega, form the famous “summer 
triangle”: Deneb and Altair.  You can either click on the stars if you recognize them or use 
the Find tool (binocular button).  For each of Vega, Deneb, and Altair, are they east or west 
of the meridian at 8:00 PM?  This is important because our telescope mount requires a large 
movement to change its pointing from slightly west to slightly east of the meridian (the 
reason will become apparent when observing).  Also identify the stars Arcturus and Antares 
and list what side of the meridian these are on. 

c. Q4)  With the display, date, and time set as at the beginning of the problem.  Start zooming 
in.  Continue until a rectangular red box with a ring around it appears.  This is the footprint of 
the telescope’s CCD camera on the sky.  The smaller rectangle in the ring is the field of view 
of the guide CCD.  Click on the brightest star in the big rectangle (biggest dot, though check 
magnitudes if you are unsure).  What is the name of this star and is it east or west of the 
meridian.  Zooming  in like this will be the first step in setting up the telescope for observing 
(more on this later). 

5) Continue on to answer the questions below.  Remember that, after you are done with The Sky and 
exit the program, always answer NO to the question about saving the changes that you have made.  
Everyone is using the same version of the program and life is much simpler if we maintain a uniform 
setup.  If you use the computer in the dome, shut it down since it is still getting hot in there during 
the day.  You can leave the computer in room 401 on (though log off). 

 
Q5)  What planets are observable from the Schommer Observatory at 8:00 pm on September 13, 2018?  
List the constellation in which each appears.  You can turn on constellation name labels in the Display 
Explorer under Reference Objects → Reference Lines → Constellation Figure.  If a planet seems to be 
between two constellations, turn on Constellation Boundaries in that panel or the Reference lines panel.   
 
Q6)  Set the time to 9 pm (21:00:00) – you can either do this directly or by setting the time step to 1 
hour and using the Step Forward button.  Make a sketch of the full sky with the five bright stars from 
Q3 on it along with Mars, Jupiter, and Saturn.  Label each with its name, magnitude, and, for the stars, 
spectral type.  Make sure that your sketch includes labels of the cardinal directions along the horizon.  
On a clear night, find these objects in the real sky and note their relative apparent brightness and color.  
Include the date and time of this visual observation in your report. 
 
Q7)  Adjust the time step to 1 hour and advance the display with the Step Forward button.  Describe 
how the appearance of the sky changes.  What major solar system objects (i.e., excluding comets and 
asteroids) are visible on September 14, 2018 at 6:00 am, just before sunrise? 
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Q8)  What is the first day during the semester (approximately) when the GK Per (which can be searched 
for as “GCVS GK Per”, is 30 degrees above the eastern horizon at 10 PM?  At 8 PM?  You may need to 
watch out for the effect of daylight savings time, which ends on November 4th this year. 
 
Q9)  Set the date and time to 8:00 PM, September 1, 2018.  Turn off the daytime sky mode (if it is on) 
and select a time step of 23 h 56m 04 s (one Sidereal Day).  Use the Go Forward button and carefully 
observe the motion of the planet Jupiter with respect to the stars until September 1, 2019.  Describe this 
motion in detail.  Why are the stars stationary in the display when skipping forward by one sidereal day? 
 
 
Part II 

1. Use VNC to connect to your computer account on the “astrolab” computer (see the VNC handout for 
details).  Create a lab1 subdirectory (a folder in Window-speak) and copy the files “moon.fits” and 
“m31.fits” from the /home/ph344/lab1 directory into your lab1.  (For example, you can use the 
Applications → System Tools → File Browser tool from the menu at the top of your desktop.  Or you 
could issue the appropriate Linux commands in a terminal window, if you know them.)   

2. Get a terminal window by clicking on the terminal symbol at the top of your desktop.  Start the IDL 
Developers Environment by typing the command idlde (followed by a return). To make an icon on 
your desktop for easy access, right click on the desktop, and select the “Event Launcher”; click 
“Browse” and navigate to /usr/local/bin/idlde; click on “OK”.  Thereafter, clicking on this icon will 
start idl for you.  

3. Set your path in IDL: in IDLDE, click on window/preferences, then select IDL and Paths; click on 
Insert, and then in the Places window navigate to File System and double click.  Then navigate to 
/usr/local/src/idl (make sure idl is highlighted) and click OK.  This path will be added to the path 
window.  Check the box preceding this item to include the subdirectories.  Then click Apply and OK.  
You only need to do this once, and then the IDL astronomy libraries will be automatically added to 
your path every time you run IDL. 

4. There is a lot to learn about IDL.  In this lab we focus on the image display tool RUPhAst, which is 
the local Rutgers version of the PhAst tool and is a program written in IDL.  A moderately-useful 
manual for PhAst is available on the class websites.  For mysterious reasons perhaps deeply 
connected to the level of entropy in the universe, before running RUPhAst issue the command “.run 
ruphast <return>”  − TWICE – at the IDL> prompt in the IDL Console  (at the bottom of IDL 
widget).  You will see many messages about modules being compiled but should see no error 
messages.  You can then start the RUPhAst widget by typing “ruphast <return>” at the prompt.  The 
first time you start RUPhAst it will ask to create a directory called output – say yes. 

5. Read the image moon.fits from your lab1 subdirectory using “Read Fits File” under “File” in the top 
menu bar.  Change the “Mouse Mode” to “Color”.  You can then adjust the display contrast and 
brightness by holding down the left mouse button and dragging: left-right changes the brightness, 
and up-down changes the contrast.  Try zooming the image with the buttons on the PhAst tool, and 
panning the zoomed image by dragging the green outline in the small window.  Note that clicking 
the right mouse button centers the display on the location of the cursor. 

6. Read through the RUPhAst help (rightmost of the RUPhAst menus).  See what typing the r, c, and i 
keys (with the cursor somewhere on the image) does.  Use the “i” key to inspect the statistics for the 
pixel values in an 11 x 11 box centered on the cursor location.  You can change the size of the box 
by typing a number in the “Box Size for Stats” box and then pressing the enter key.  The number 
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isn’t recognized until you press enter – this is a generic feature of the graphical user interface built 
into IDL. 

7. Find the coordinates (x,y) and brightness value of the brightest pixel in the image of the Moon.  You 
may find the “Pixel Table” in the “ImageInfo” menu useful.  Measure the diameter (in pixels) of the 
bright crater Tycho, which is located at about the (x,y) location (1255, 1350) in the image.  Plot a 
row and a column passing through Tycho.  Save these plots using the “Create PS” button on the plot 
window.  Select the “Encapsulated (EPS)”, and deselect the “Color Output” settings, and use the 
“Choose…” button to navigate to your local directory, then change the extension from “.ps” to 
“.eps” and save the file.  You should use a more descriptive file name than the default “phast_plot”.  
The Open Office Writer can insert these .eps files directly into your lab report.  If you want to print 
these plots, you will need to copy them to your local computer (using ftp in ssh) and then use your 
printer. 
Experiment with the “s” and “t” keys in the vicinity of Tycho.  Also include one each of these plots 
with your lab writeup. 

8. Load the m31.fits image using “Read Fits File”.  This is a field containing (some of) the galaxy M31  
taken with our telescope.  What was the exposure time of this image and what date and time was it 
taken?  What filter was used?  (Hint: use the “ImageInfo/ImageHeader” menu item.)  Use the “Full 
Range” and “Auto Scale” buttons to experiment with changing the display map.  (Full Range maps 
the brightest pixel to white and the faintest to black; Auto Scale maps a smaller range of “most 
common” pixel values to the grey scales from black to white.)  For this image, even autoscale does 
not do the best job.  Set the minimum (black) display value to 1500 and the maximum (white) to 
20000 by typing those numbers in the Min and Max boxes (remembering to hit return).  Experiment 
with adjusting the brightness and contrast using the left mouse button.  Estimate the (x,y) 
coordinates of the bright central nucleus of M31.  What is the value of the brightest pixel in the 
center of the galaxy? 

9. With the cursor on the star at (750, 1495), press the “p” key.  Report the aperture radius, and inner 
and outer sky radii chosen by the program and reported in the photometry popup window.  Press the 
“Show Radial Profile” button (if it is not already selected) to see the pixel values (yellow points) and 
a fitted Gaussian (solid line).  Report the FWHM (full width at half maximum intensity), the sky 
level (in ADU), and the object counts (in ADU) for this star.  Note that the “object counts” value is 
the sum of the pixel values within the aperture radius minus the contribution from the “sky” 
background, estimated from the values of the pixels between the inner and outer sky radii.  Finally, 
also report the SNR (Signal-to-Noise Ratio) of this measurement. 

10. Put the cursor on the star at (2245,455) and press the “p” key.  Note how the radial profile of this star 
has a flat top near a value of 64,000.  This star is “saturated” – it is so bright that the pixel signal 
values were larger than the analog electronics of the CCD detector system could handle, and all 
information about the bright portions of the star has been lost.  What is the reported FWHM of this 
star?  Explain why this is different from the FWHM of the star of the previous question.  How would 
you change the way the image was taken to obtain useful information about the brightness of this 
star? 


